image
image
image

Votre IP : 54.162.218.214
Dernier ajout : 20 septembre
Visiteurs connectés : 17

image Conception
Développé sous SPIP
Informations légales

image
image
Recherche image

Pratiques et Techniques de la Plaisance

image

Accueil du site > Forum technique > Electronique, instruments -forum- > Bus NMEA/Seatalk > Trames NMEA Navman serie 100 ?

Rubrique : Bus NMEA/Seatalk

__________________________________________________________________________________________________________________

Trames NMEA Navman serie 100 ?Version imprimable de cet article Version imprimable

Publié 29 juin, (màj 29 juin) par : Lobs   

Copyright : Les articles sont la propriété de leurs auteurs et ne peuvent pas être reproduits en partie ou totalité sans leur accord
S'identifier pour s'abonner par mail

Bonjour,
Afin de fignoler mon installation OpenCpn/Miniplex2/Seatalk..... Etc
Et dans l’idee d’utiliser au mieux mon repetiteur Navman 100 (4 entrees NMEA)

Je cherche a savoir « a quoi ressemblent » les sorties NMEA des instruments Navman de la serie 100 ??

Il me restera (au moins l’espoir) a tenter de les imiter pour optimiser l’affichage des infos du Bidata ST40 vers le Navman Repeat
Si il reste des utilisateurs de la serie 100 !!! Merci....
A+, Lolo

UP


Répondre à cet article
(pour répondre à un message en particulier, voir plus bas dans le fil)

28 Messages de forum

__________________________________________________________________________________________________________________

__________________________________________________________________________________________________________________

  • 4 juillet 11:08, par Lobs écrire     UP

    Hello
    Vu le peu de pistes de reflexion qui s’ouvrent a moi,
    j’ai tenté (sans grande conviction, je dois l’avouer) de contacter le SAV Plastimo !
    Malgres l’age avancé de mon Repetiteur (ca date de quand la serie 100 ?)
    J’ai eu un long echange avec un gars du SAV :

    Respect ! Bravo Plastimo... Quand meme !

    Bon ca ne m’avance pas trop... D’apres lui le soft du Navman 100 ne lit pas les ID
    Bref... Normalement ca devrait fonctionner.
    Il me propose de faire un Reset (et m’a donne la procedure) et de recommencer le Setup.
    Me reste a le faire a ma prochaine visite. J’en profiterai pour verifier si toutes les trames necessaires sont bien dirtigées
    Vous voila informés ;-)
    A+, Lolo

    Répondre à ce message

    • Pour les lecteurs ultérieurs, ce fil est dans le prolongement de celui là : http://www.plaisance-pratique.com/P...

      Ceci dit, j’ai déjà vu ici où là que le ID NMEA (les 2 premiers caractères, à l’origine c’était surtout GP) était ignoré par certains équipements, et c’est légitime, surtout si un répéteur les réécrit. Les 3 caractères suivants, eux, sont très discriminants et toujours pris en compte.

      Dans les tests que tu mènera n’oublie pas que le shipmodul est capable d’envoyer vers une sortie donnée une trame que tu aura fabriqué à la mano, le shipmodul calculant le checksum pour toi (option dans mpxconfig, je crois). Ca devrait te permettre d’agacer ton navman de manière probante.

      Bon courage.

      Répondre à ce message

      • Merci Yves de preciser que c’est effectivement la continuité de l’autre fil.
        Mais comme je trouvais ce « détail » en dehors du sujet du 1er fil, j’ai prefere en faire un autre ! :)

        Je reviens du bateau... c’est marrant comme je prefere le vernis au NMEA0183 ! :o)

        Les resultats du vernis sont hyper concluants.
        Coté Retetiteur, c’est une autre histoire.... Non seulement je n’ai pas pu l’aggacer, mais lui est a deux pixels d’y arriver !!! :-((

        Il recoit plein d’infos en NMEA, et je les retrouve bien dans le Setup.
        Il les affiche en « mode NMEA »

        JPEG

        Répondre à ce message

        • J’ai jeté un coup d’oeil sur la doc Raymarine du ST40 bidata (demander à gogol, il trouve ça http://www.aes-plaisance.fr/Raymari... )
          C’est un combiné loch+sondeur.
          La doc précise que son interface (son unique interface) est de type SeaTalk (donc pas d’interface NMEA). Il faut donc le raccorder au shipmodul à un port configuré en ST, ce que tu as déjà fait avec succès, et le shipmodul assurera la traduction ST -> NMEA (je ne suis pas sur de l’inverse, est-ce pour ça que j’ai acheté le convertisseur 80008 de raymarine ?).
          Ce qu’émet un ST40 ce sont des trames SeaTalk (demander à gogol la liste de ces trames). Certaines trames (mais pas toutes, ça j’en suis sur) sont reconnues par le shipmodul et traduites en phrase NMEA. Je ne sais quelles trames NMEA sont produites, mais puisqu’on sait que le shipM assure au moins en partie sa fonction il vaut sans doute mieux demander à OCPN (plutot qu’à mpxconfig) ce qu’il voit comme trames et essayer de deviner lesquelles viennent du ST40. S’assurer bien sur que les trames ST reçues par le shipM sont bien retransmises sur l’interface destinée à OCPN (et accessoirement au navman), ça concerne la profondeur, la températeur, la vitesse sur le fond.

          Pour info mon ST40 loch et le ST40 wind émettent des trames ST qui une fois traduites deviennent des phrases NMEA, qu’ensuite OCPN (en fait VDR mais c’est pareil) reçoit

          • trames que le convertisseur ST - NMEA peut produire/traduire, remarque qu’il les préfixe d’un II à partir des trames ST des ST40 Wind et Speed

          $IIBWC,,,,,,,T,,M,,N,*01 Bearing and Distance to Waypoint
          $IIHDG,049.5,,,,*41 Heading – Deviation & Variation
          $IIMWV,165.0,R,6.8,N,A*31 Wind Speed and Angle
          $IIVHW,,T,049.5,M,0.00,N,0.00,K*73 Water Speed and Heading
          $IIVPW,0.00,N,0.00,M*52 Speed – Measured Parallel to Wind
          $IIVWR,165.0,R,6.8,N,3.5,M,12.6,K*76 Relative Wind Speed and Angle
          $IIVWT,165.0,R,6.8,N,3.5,M,12.6,K*70 déconseillé, préférer MWV
          $IIMTW,21.4,C*14 Water Temperature
          $IIMWD,,T,210.0,M,7.0,N,3.6,M*6B Wind Direction & Speed : UNKNOWN
          $IIVLW,2251.7,N,0.00,N*4E Distance Traveled through Water

          • phrases NMEA que OCPN/VDR ont enregistré, celles provenant du ST/shipM sont préfixées II, dans le lot il y a des trames venant du compas électronique ST50, mon sondeur ($SD) semble éteint.

          $GPRMC,190653.00,A,4608.83191,N,00109.89653,W,0.069,151.38,261015,,,A*75 _ !AIVDO,1,1,,,B3HWV`0007vbcEVVOGuNWwrUsP06,0*19
          $IIVHW,,T,060.0,M,0.00,N,0.00,K*7D
          $IIVPW,0.00,N,0.00,M*52
          $IIVWR,028.5,R,4.2,N,2.2,M,7.8,K*4F
          $IIVWT,028.5,R,4.2,N,2.2,M,7.8,K*49 _ !AIVDO,1,1,,,B3HWV`0007vbcF6VOGqNWws5sP06,0*1F
          $IIBWC,190654,,,,,,T,,M,,N,*0E
          $IIGLL,4608.829,N,00109.896,W,190654,A,A*4B _ !AIVDM,1,1,,A,18IhLF0000OrHc8JJ=SThGAf0@P5,0*0D
          $IIHDG,060.0,,,,*4F
          $IIHDM,060.0,M*24
          $IIMWV,028.0,R,4.4,N,A*37
          $IIMWV,028.0,T,4.4,N,A*31
          $IIVHW,,T,060.5,M,0.00,N,0.00,K*78
          $IIVPW,0.00,N,0.00,M*52 _ !AIVDO,1,1,,,B3HWV`0007vbcF6VOGmNOwsUsP06,0*7B
          $IIVWR,028.0,R,4.4,N,2.3,M,8.1,K*4B
          $IIVWT,028.0,R,4.4,N,2.3,M,8.1,K*4D
          $IIGGA,190655,4608.829,N,00109.896,W,1,08,1,-5,M,37,M,,*74
          $IIMWD,,T,088.0,M,4.4,N,2.3,M*6B
          $IIVLW,2251.7,N,0.00,N*4E
          $GPGGA,190656,4608.8290,N,00109.8959,W,1,8,1.9,-6,M,37,M,,*4E _ !AIVDO,1,1,,,B3HWV`0007vbcF6VOGiNSwt5sP06,0*04
          $IIBWC,190656,,,,,,T,,M,,N,*0C
          $IIGLL,4608.829,N,00109.895,W,190656,A,A*4A
          $IIHDG,060.0,,,,*4F
          $IIHDM,060.0,M*24
          $IIRMC,190656,A,4608.829,N,00109.895,W,,,,,,A*7D
          $IIMWV,028.0,R,4.8,N,A*3B
          $IIMWV,028.0,T,4.8,N,A*3D
          $GPRMC,190657.00,A,4608.83154,N,00109.89645,W,0.063,151.25,261015,,,A*79

          • C’est à rapprocher de ta question :

          DBT (Profondeur)
          VHW (Vitesse)
          MTW (Temperature)
          et pas le VLW

          moi je le reçois le VLW. Bizare, serait-ce une trame ST non interprétée par le shipm, qu’en dit la doc ?
          Un bateau à l’arrêt c’est une vitesse = 0, c’est pas une absence de VLW ou VHW

          Répondre à ce message

      • Il recoit bien les trames du Bidata (sonde et vitesse) (Photo 2)

        JPEG

        Répondre à ce message

      • Mais en mode « multi » il n’affiche que dalle..... (Photo 4)

        M’faudrait une copie d’une trame NMEA d’un Speedo ou sondeur NAVMAN serie 100, sans ca je ne vois pas comment faire ????
        Doit bien rester qqun qui utilise ca avec OpenCpn, non ? |-)

        PS : J’ai pas trouver de moyen d’integrer des images, ni de mettre plusieurs fichiers ???

        MERCI
        A+, Lolo

        JPEG

        Répondre à ce message

  • 6 juillet 23:42, par Lobs écrire     UP

    Yves.... MERCI !
    Tu serais pas du coté d’Arzal des fois ? :)

    Alors, je vois que je progresse un peu, et que j’ai bien relu pas mal de choses, parce qu’a te lire, je vois de suite de quoi tu parles !

    Pour tenter de limiter les risques d’ aneries, j’ai viré depuis la config du GPS, tout ce qui concerne la profondeur.
    Les entrées 1 et 2 et sortie 2 (tout a 38,4k) du Shipmodul sont destinées a la VHF et GPS (AIS)
    Reste UNIQUEMENT l’entree 4 pour le Bidata à convertir.
    SEUL le ST40 sort DBT, MWV et VHW
    D’ailleurs je m’etais fait un « tableau de bord » s/s OpenCpn, et il lit bien vitesse et profondeur.
    Sur l’entree 4 je lis :

    $SDDBT,22.0,f,6.7,M,3.6,F*32
    $VWVHW,,,,,0.00,N,0.00,K*4D
    $WIMTW,25.9,C*03

    Je suis donc sur (enfin... Si quand meme !) que les infos (Speed Depth et Temp) lues par le R100 sont en provenance du Bidata.

    VLW fait partie des datagrammes traduits en NMEA (ST 21. 22 et 25) Page 45 de la Doc Miniplex

    Je vais verifier dans la doc Bidata si ils cozent sorties ST
    A+, Lolo ;)

    Répondre à ce message

    • 7 juillet 10:36, par yvesD écrire     UP     Ce message répond à ... Animateur

      Je suis donc sur (enfin... Si quand meme !) que les infos (Speed Depth et Temp) lues par le R100 sont en provenance du Bidata.

      Sur ma mienne, j’ai testé assez systématiquement ce que chaque producteur produit, en isolant tous les autres histoire d’etre sur et certain. Et bien évidemment les fichiers de log font partie de ma doc. ça simplifie considérablement l’identification ultérieure des pannes.

      Méfie toi des phrases NMEA identiques et venant de plusieurs sources (la profondeur et ton gps et ton bidata), c’est astucieusement traité par le shipm, mais on peut s’y prendre les pieds. Comprend bien (lire la doc) comment sont traitées les boucles de données, donnée reçu de X et qu’au final tu repasse à X.
      D’ailleurs, à l’occasion, puisque tu a GPS et AIS donc deux sources de position GPS, tu poura un jour utiliser l’un en source primaire et l’autre en source de secour (lire la doc du ship, bien sur, et tester et constater)

      J’ai été assez déçu par la doc raymarine récupérée via gogol (post précédent), il n’y est pas fait mention des trames seatalk (pas là dedans en tout cas), ce qui peut s’expliquer par le caractère fermé de (l’excellent protocole) SeaTalk. Tu sera forcé de ne conaire de ces trames que ce que le shipm (port #4) veut bien traduire. Là aussi faut noter dans la doc du bord.

      Bonne chance

      Répondre à ce message

      • Hello

        Mon installation a le merite d’etre hyper simple.
        Je n’ai pas d’AIS, seule la VHF me sert de recepteur AIS.

        Voila toutes les trames qui sortent du Miniplex :
        Je les ai separées par entrées (Mais j’ai pas noté les entrées c’etait bien dans le fichier Log, j’ai juste modifié la mise en page).

        1= GPS
        2= VHF (Ais)
        3= Rien
        4= Bidata Seatalk

        1\$GPRMC,074238,A,4729.8237,N,00222.4026,W,0.0,127.9,060717,2.8,W,D*10
        1\$GPRMB,A,,,,,,,,,,,,A,D*0E
        1\$GPGGA,074238,4729.8237,N,00222.4026,W,2,09,0.9,1.3,M,50.3,M,,*59
        1\$GPGSA,A,3,06,,12,14,15,17,19,24,25,,32,,1.5,0.9,1.2*36
        1\$GPGSV,3,1,12,06,11,075,35,10,11,260,00,12,84,021,50,14,21,316,35*72
        1\$GPGSV,3,2,12,15,16,171,44,17,08,032,39,19,24,044,44,24,62,107,46*72
        1\$GPGSV,3,3,12,25,52,250,47,29,08,190,00,32,38,303,43,33,34,198,43*78
        1\$GPGLL,4729.8237,N,00222.4026,W,074238,A,D*5E
        1\$GPBOD,,T,,M,,*47
        1\$GPBWC,074238,,,,,,T,,M,,N,,D*74
        1\$GPVTG,127.9,T,130.6,M,0.0,N,0.0,K,D*2F
        1\$GPXTE,A,A,,,N,D*54
        1\$PGRME,2.0,M,2.5,M,3.2,M*2A
        1\$PGRMM,WGS 84*06
        1\$GPRTE,1,1,c,*37
        1\$GPAPB,A,A,,,N,A,V,,,,,,,,D*75

        2\ !AIVDM,1,1,,A,D02 ;bD@kTLfq8dM6EKDu6D0,2*01

        4\$SDDBT,22.0,f,6.7,M,3.6,F*32
        4\$VWVHW,,,,,0.00,N,0.00,K*4D
        4\$WIMTW,25.5,C*0F

        Vouala... J’ai viré a la source toute possibilité de doublon
        J’ai tenté d’attribuer manuellement au Bidata la trame VLW, sans resultat.

        Sur la doc Miniplex a propos des « traductions » ST/ NMEA, je lis que :

        00=DBT (Profondeur sous sonde)
        20=VHW (Vitesse et cap)
        21=VLW (Distance voyage (21 et 22 combinés)
        22=VLW (Distance Totale (21 et 22 combinés)
        25=VLW (Distance voyage et totale)
        26=VHW (Vitesse et cap)
        27=MTW (Temperature de l’eau)

        Est ce que c’est pas les 3 VLW qui seraient mal geres par le traducteur du miniplex ??? (Je pourrais p’tet poser la question chez Shipmodul ?)

        Il est a noter aussi que OpenCpn par l’intermediaire des « Tableaux de Bord » recoit et decode tres bien les trames ci-dessus
        Vitesse et profondeur OK. Pas de log (—)
        Les infos se croisent et confirment que, en sortie du Miniplex, on a :

        Pas de trames VLW (Et ca manque vraiment !)
        Des trames DBT et VHW « incompatibles » avec l’affichage « Multi » du Navman Repeat. (Ca serait mieux avec, mais c’est pas la cata non plus)

        V’la les deux problemes qu’il reste... C’etait tellement pire que c’est deja un succes ! B-)
        A+, Lolo

        Répondre à ce message

        • 8 juillet 07:34, par lysigée écrire     UP     Ce message répond à ...  image Animateur

          « Est ce que c’est pas les 3 VLW qui seraient mal geres par le traducteur du miniplex ??? »
          Sur mon installation (ST60, shipmodul), les trames VLW, décryptées que je vois dans mon log Shipmodule correspondent parfaitement à l’information Trip que je lis sur mon afficheur ST60, et sur la page correspondante de l’afficheur de mon pilote alimenté directement par Seatalk.. Elles sont donc parfaitement traduites.
          une des lignes vlw en sortie du shipmodul
          NMEA183:2017-06-26Z13:25:56.031 :$IIVLW,10929.4,N,31.81,N*41
          En revanche, mon logiciel de nav (Scannav) n’a pas prévu de les afficher dans ces répétiteurs. Je ne suis pas familier avec OpenCpn, mais je ne les vois pas non plus dans le « tableau de bord ». Je ne les vois pas non plus dans le logiciel de nav Sailgrib sur tablette.
          Et je comprends que tous ces logiciels ne s’en préoccupent pas, et pour deux raisons :
          1- les informations VLW dépendent d’une part de la date/heure de l’initialisation du bidata, et non pas du vrai début de la route. par exemple, je suis mouillé mais par un fort vent, et mon bateau « navigue » de droite à gauche ; depuis 2 heurs j’ai déjà parcouru 1.5 milles, alors que je suis toujours accroché à mon ancre
          2- l’information Distance est la distance sur l’eau, et dépend d’une part de la précision du capteur de vitesse, d’autre part du courant rencontré.
          précision donc toute relative : Par exemple, la trame que je montre indique que j’ai parcouru depuis l’installation du ST 10929 milles, alors que l’addition de toutes mes traces me donne 17894., et que la distance du jour me donne 31.81 milles, alors que ma trace m’indique 34.56
          Je préfère donc pour connaître la distance parcourue, interroger l’information que me donne Scannav par rapport à ma trace (Sur OpenCPn, je suis sur qu’on peut le faire aussi),
          Même à l’époque où le GPS n’existait pas, je ne me suis jamais fié à cette info pour calculer mon estime, préférant calculer la distance parcourue, en la calculant moi même sur ma carte papier, avec toutes les incertitudes liées au positionnement par relèvement.
          Robert
          S/Y Lysigée
          en photo l’explication des infos de la tram VLW

          PNG

          Répondre à ce message

          • 8 juillet 09:01, par yoruk écrire     UP     Ce message répond à ... Animateur

            Alors, merci Robert, par contre, pour OpenCPN

            Comme déjà indiqué, on peut sélectionner un type de phrase à recevoir ou à expédier. Cà se passe par : outil > Connexion > Ajouter une connexion > Filtrer en entrée ou/et en sortie. Un choix de phrases standards est proposé, mais on peut en installer d’autres

            Pour l’affichage des informations, c’est effectivement le tableau de bord qu’il faut consulter et mettre à jour. Voir, la copie d’écran jointe qui montre la vitesse sur l’eau et celle sur le fond. De nombreuses options sont proposées, dont celle de la distance cumulée... Mais je ne saurai en dire plus, me contentant de relever mes distances journalières, à partir des propriétés de la trace : clic droit plein écran sur la trace.

            Voilà pour le peu que je puisse apporter...
            Michel

            JPEG

            Répondre à ce message

          • 8 juillet 16:24, par yvesD écrire     UP     Ce message répond à ... Animateur

            Bon rappel lysigée, effectivement, les 3 trames du ST40 tournant autour du loch contribuent à fabriquer une seule phrase NMEA ... dans laquelle seule l’information de vitesse instantanée sur l’eau est vraiement utile pour nous qui sommes équipés de logiciel de nav qui calculent très bien ce qu’on peut en tirer (dont la vitesse fond). Qand aux distances annoncées par ces trois trames ou leur équivalent NMEA, c’est du pur folklore historique, nos GPS ont des précisions diaboliquement plus diaboliques qui les relèguent au rang d’aimable plaisanterie (relire à ce sujet ce qu’écrit Marguet, sur ce site, à propos de l’histoire des courants).

            Répondre à ce message

  • 8 juillet 09:28, par yoruk écrire     UP Animateur

    Voir aussi les options de conversion des phrases NMEA :

    Répondre à ce message

    • 8 juillet 14:44, par yvesD écrire     UP     Ce message répond à ... Animateur

      Ah, ça peut aussi faire ça OCPN ?
      Bon, bien sur, faut lire ce manuel ... et le comprendre. Mais à priori bien aguichant.
      Merci du tuyau
      yves.

      PS : c’est dans quelle version de OCPN ? [ajout à postérioiri : suffit de regarder la copie d’écran, c’est du 4.6.1]

      Répondre à ce message

      • 8 juillet 16:28, par yoruk écrire     UP     Ce message répond à ... Animateur

        Je te sais religieusement conservateur... Ce qui n’est pas défaut, quand c’est exercé avec modération :-))

        Mais tu peux passer à la dernière release , v 4.6.1, parfaitement stable, en particulier sur deux plugins bien finalisés : Dashboard et Grib.

        • Dashboard, très abouti, est le produit d’un français : Jean-Eudes Onfray (c’est le même nom de famille que son père... comme quoi il ne faut désespérer de rien)
        • Grib initialement développé pour zyGrib, a été amélioré, en particulier par J.P Joubert, autre français, que l’on croise aussi sous son pseudo « ptizef »

        Je me méfie beaucoup des autres plugins, très hétérogènes et dont la finalité maritime me pose question... en particulier celui du routage
        Michel

        NB J’ai traité tout celà en tutoriel, mais les développeurs américains on fait un boulot remarquable, et probablement avec uns CMS bien meilleur que notre SPIP, voir :

        Répondre à ce message

  • 9 juillet 00:17, par Lobs écrire     UP

    Merci tout l’monde ! |-)

    Robert
    Oui je suis bien de ton avis concernant l’interet tres limité des trames VLW.
    Dans l’etat d’avancement de mes cogitations NMEAziennes (lol)
    l’idée c’est plus de comprendre ce qui et pourquoi ca ne marche pas.
    J’me disais que le repetiteur pouvait « ne pas entendre » un Speedo puisqu’il manque les trames VLW ???
    Je cherche des pistes....

    Avant mon bateau etait en Loire, il en a fait des 100aines de miles amaré a sa bouée ! :)

    Je note quand meme dans ta trame, l’ID « II ».... Merci, j’aime bien cette piste des ID
    Meme si Le SAV Plastimo me dit que le R100 ne decode pas les ID (Du coup j’ai pas essayé, j’aurais du !)

    Yoruk...
    Coté OpenCpn, je suis a la version 4.0.0, j’ai egalement les Grib animés et les tableaux de bord.
    J’ai essayé la version 4.6.1, et sur mon T100 ca ne marche carrement pas.
    TRES TRES lent, au point de ne pas arriver a faire un zoom (Manque de memoire ???).
    Je suis revenu vite fait a la version 4.0.0.... Qui fait vraiment bien l’boulot.
    En meme temps, vu mon programme de nav (balades), je ne suis pas difficile.

    Deux infos importantes :
    J’ai une Cde a essayer qui va me permettre de « voir » dans MPX-Config les trames SEATALK qui sortent du Bidata ST40. Comme ca il n’y aura plus de doute. (Merci Martin ! :) )

    Je suis toujours a la recherche d’une copie de trames en provenance d’un Navman S100 ou D100 ou M100 !
    MERCI a tous (Je ne pourrai pas retourner au bateau avant 15j...)
    A+, Lolo

    Répondre à ce message

  • 30 juillet 23:06, par Lobs écrire     UP

    Hello
    Qqs news suite a mes derniers essais a bord :
    J’ai utilisé la Cde $PSMDOP,C,4,1 qui devrait monter les trames SEATALK a l’entree(4) du Miniplex.
    Deux nouvelles lignes apparaissent :

    $IIMDST,60,0C,01,00,00,00,00,00,00,00,00,00,00,00,01*57
    $IIMDST,24,02,00,00,00*26

    J’attends la « traduction officielle » de ses lignes pour savoir si ca abouti a qq chose de positif.... Ou pas....

    Vous pouvez voir que j’ai tenté de changer l’ID du Bidata, en GP puis II... Sans resultat sur l’affichage du Navman Repeat. (Reset et re-Setup a chaque fois)

    BREF... Ca n’avance pas de ce coté.
    Bon, meme si c’est pas super grave, je me dis qu’il existe une solution assez simple :
    Monter un Bidata ou Tridata Seatalk a l’exterieur a coté du Repetiteur ! (Qui me servirait que pour le GPS du coup) :)

    Si vous avez ca BI ou Tridata (ST40, I40, ST60, I50... etc) CA M’INTERESSE !
    A+, Lolo

    Répondre à ce message

    • 31 juillet 13:16, par yvesD écrire     UP     Ce message répond à ... Animateur

      RTFM comme d’hab ;-), et peut-être en causer à shipmodul, si leur SAV est aussi compétent que leurs codeurs et auteurs de manuel, le succès est assuré

      page 45 (un résumé) du manuel Miniplex_2_EN on peut lire
      When the SeaTalk translation is enabled with option 2 (the s parameter in the CF sentence is 2), unlisted datagrams are translated into a proprietary NMEA sentence with the following format :
      $PSMDST,aa,bb,cc,dd…*hh
      aa,bb,cc,dd… represent the hexadecimal value of the bytes from the received SeaTalk datagram.

      le CF me laisse sans voix, comprend pas bien.

      La commande interne (== pas NMEA 183) shipmodul PSMDOP est décrite page 51, et page 52 on peut lire
      4 : Convert SeaTalk datagrams into $PSMDST,xx,xx,… sentences. Datagrams are only converted if they are not translated into NMEA. When option 3 is enabled, only unknown datagrams are converted, otherwise all datagrams are converted. . This will also be reflected in the $PSMDIN response : input 5 will report SeaTalk mode.

      Donc ton $PSMDOP,C,4,1 va convertir les datagrammes ST en $PSMDST et tous les datagrammes sont convertis. Avec l’option 3 (plutot que 4, cf p. 52), c’est uniquement ceux qui ne sont pas traduit en NMEA qui deviendront des $PSMDST
      Essayer 3 pour voir, mais que conclure alors ?

      Ceci dit tu n’es sans doute pas très avancé, faut sans doute en causer à shipmodul.

      concernant les 24 et 60 des phrases MDST je n’y retrouve pas un code de datagram ST (selon p45), je m’y perd.
      concernant le II (integrated instrument, selon NMEA 183) c’est le shipmodul qui fabrique ça, et c’est à mon avis sans incidence, tous les receiver comprennent une tramme NMEA quelqu’en soit la source (GP, II, ...)

      Répondre à ce message

      • Salut, tous, salut Yves...
        Oui cette Cde (PSMDOP) m’a ete soufflée par Martin de chez Shipmodul pour verifier ce qui sort du Bidata.
        Sa reponse me laisse sur ma faim :

        « Pas de datagram 25 (distances) a transformer en VLW »
        « On ne connait pas le datagram 60 » (Effectivement je ne retrouve rien a son sujet !?!)

        Rien au sujet du datagram 24 ??

        Bref.... Je pense que je vais en rester la... Sauf miracle ??? :)
        MERCI
        A+, Lolo

        Répondre à ce message

        • 4 août 12:55, par yvesD écrire     UP     Ce message répond à ... Animateur

          De ton dernier post j’en déduis que les 2 phrases
          $IIMDST,60,0C,01,00,00,00,00,00,00,00,00,00,00,00,01*57
          $IIMDST,24,02,00,00,00*26
          sont les seules produites par le bidata
          [pour t’en assurer, tu débranche ou déconnecte tous les talker NMEA, dont GPS, sauf le bidata tu valide la conversion par un PSMDOP de type 3 ou 4 et tu vérifie qu’il n’y a pas de différences, les seules trames reçues sont de type inconnu]

          Martin@shipmodul à bien noté :

          1. absence de trame 25 ermettant de faire du NMEA VLW
          2. présence de trames inconnues 24 et 60

          D’après la référence en matière de SeaTalk (Thomas Knauf, ici http://www.thomasknauf.de/rap/seata... mais aussi ici http://www.thomasknauf.de/rap/seata... accessible depuis http://www.thomasknauf.de/seatalk.htm et particulièrement ’collision management’ où est décrite toute la beauté de SeaTalk pour utiliser le 8055 pour réaliser un bus) la trame 24 sert à préciser les unités (M, mph, km/h), elle n’est pas inconnue mais n’a pas à être traduite, la 25 donne(aurait donné) le ’total & trip log’ et la 60 ... est inconnue au moins de TK

          Ma conclusion est que ton bidata n’a pas un fonctionnement nominal (en français, il déc..ne sévère). Sauf à restaurer ce fonctionnement (’reset to factory default’ si tu sais faire et si ça existe, remplacer la pile de backup de la config s’il y en a une, etc.) ton appareil a un pied dans la tombe et l’autre sur une peau de banane. Poubelle ?

          Dans un post suivant je joindrai la liste des datagrammes supportés, selon TK.

          Répondre à ce message

          • Lors des derniers essais, tout etait debranché sauf Bidata et Repetiteur.
            la Cde PSMDOP,C,4,1 me renvoyait

            $IIMDST,60,0C,01,00,00,00,00,00,00,00,00,00,00,00,01*57
            $IIVHW,,,,,0.00,N,0.00,K*4C
            $IIMTW,25.9,C*1D
            $IIVHW,,,,,0.00,N,0.00,K*4C
            $IIMTW,25.9,C*1D
            $IIVHW,,,,,0.00,N,0.00,K*4C
            $IIMTW,25.9,C*1D
            $IIVHW,,,,,0.00,N,0.00,K*4C
            $IIMTW,25.9,C*1D
            $IIVHW,,,,,0.00,N,0.00,K*4C
            $IIMTW,25.5,C*11
            $IIMDST,60,0C,01,00,00,00,00,00,00,00,00,00,00,00,01*57
            $IIVHW,,,,,0.00,N,0.00,K*4C
            $IIMTW,25.5,C*11
            ** j’ai supprimé 4 fois les 2 lignes ci-dessus **
            $IIMDST,60,0C,01,00,00,00,00,00,00,00,00,00,00,00,01*57
            $IIVHW,,,,,0.00,N,0.00,K*4C
            $IIMTW,25.5,C*11
            ** j’ai supprimé 4 fois les 2 lignes ci-dessus **
            $IIMDST,60,0C,01,00,00,00,00,00,00,00,00,00,00,00,01*57
            $IIVHW,,,,,0.00,N,0.00,K*4C
            $IIMTW,25.5,C*11
            $IIMDST,24,02,00,00,00*26
            $IIVHW,,,,,0.00,N,0.00,K*4C
            $IIMTW,25.5,C*11

            Zut j’ai pas bien relu ton post, je ne sais plus si les lignes DST sont la totalité des datagrams ou seulement ceux non traduits en NMEA (Ce qui serait logique vu la liste)

            Je n’avais pas pensé a une panne du Bidata, dans la mesure ou en dehors du « reseau » il fonctionne normalement, mais c’est une piste effectivement.
            Dans tous les cas, j’arrete d’embeter Martin avec ca, mais j’ai quand meme demandé via le SAV de Raymarine a quoi correspondait ce datagram 60 ?????
            Si jamais il y avait une reponse je ne manquerai pas d’informe le forum et Martin (tres sympa)
            Merci encore Yves ! :)
            A+, Lolo

            Répondre à ce message

            • 4 août 13:51, par yvesD écrire     UP     Ce message répond à ... Animateur

              Avec le mode 4 la commande renvoie uniquement ce qe le shipmodul n’a pas sur traduire en NMEA (ceci n’est pas une raison pour ne pas essayer aussi ce type 3 la prochaine fois, et comparer avec le type 4, eh, je blague ... quoique)

              Avec tes nombreuses phrases de ton post précédent on y voit moins sombre.

              • quelque chose permet de fabriquer des VHW et MTW. MTW c’est la température de l’eau, 25,9 °C, t’es pas en Bretagne. VHW c’est ’water speed & heading" et ça dit 0 noeuds et 0 km/h. Si tu es à l’arrêt ce ’0 est normal. Si ton capteur est encrassé, c’est normal aussi. Si le bidata affiche en même temps une vitesse non nulle, c’est anormal, c’est pas bien loin de la poubelle.
              • les datagrammes SeaTalk permettant de fabriquer du water speed and heading sont les 20 et 26 (pour la vitesse surface), 84 (cap compas) 89 (cap compas selon un compas ST40) et 9C. Mais ton installation n’est pas capable de fabriquer des trames ’heading’ car absence de compas SeaTalk, donc les champs heading seront sans doute à 0, raison insuffisante pour jeter le bidata.
              • et ce datagramme 60 dans $IIMDST,60,0C,01,00,00,00,00,00,00,00,00,00,00,00,01*57 est inconnu de Thomas Knauf (voir PJ du post suivant), ce dernier a tout de même fait des ajouts entre 2005 et 2017

              Répondre à ce message

            • Euh, en relisant le manuel de référence du ST40 bidata (en PJ) je remarque qu’il est aussi sondeur, or je ne trouve pas de phrase NMEA relative à la profondeur telles que DBT ou DPT (pour l’offset de la sonde). Voir p. 22 et 23 de la ¨PJ pour des pannes possibles, selon Raymarine / SD Marine
              L’est en panne aussi d ce coté là, ton zèbre ?

              En vrac, voir aussi p 33-34-35 (pour s’assurer que le capteur de vitesse est bien raccordé)

              Une question : en autonome, il affiche bien la vitesse sur l’eau ? as-tu réussi à l’étalloner (calibration, p. 43-44).
              As-tu joué avec le mode master et/ou REPTR (p. 46), réglage qui permet d’affecter à cet afficher là le rôle de maitre ou de répéteur pour la profondeyur, mais aussi (spéarément) pour la vitesse. Des incohérences de ce coté ?

              Répondre à ce message

              • Yves... Oeil de Lynx, rien ne t’echappe ! :)
                Effectivement mes trames de sonde ont disparu !
                Bon, je les avais avant de changer l’ID du Bidata (Voir Mgs plus haut)

                $SDDBT,22.0,f,6.7,M,3.6,F*32
                $VWVHW,,,,,0.00,N,0.00,K*4D
                $WIMTW,25.9,C*03

                Ca doit etre du a une anerie dans la config du moment... Ca m’inquiete pas.

                Pour repondre a tes questions,
                Oui il fonctionne bien sur l’eau, vitesse, sonde et loch.
                Je ne l’ai pas calibré, j’ai pas bidouillé la config.... Faudrait p’tet que j’y regarde !
                Quand ca marche en general j’me casse pas la tete plus que ca ! :)

                Pour la temperature la sonde est a l’interieur (Je profite d’etre au sec pour traverser, ca sera plus efficace)
                Bon WE
                A+, Lolo

                Répondre à ce message

Répondre à cet article

UP

Copyright et informations légales