image
image
image

Votre IP : 3.89.204.127
Dernier ajout : 1er décembre
Visiteurs connectés : 10

image Conception
Développé sous SPIP
Informations légales

image
image
Recherche image

Pratiques et Techniques de la Plaisance

image

Accueil du site > Forum technique > OpenCPN -forum- > Matériel connecté et microordinateur -forum- > opencpn / piolote raymarine 3

Rubrique : Matériel connecté et microordinateur -forum-

__________________________________________________________________________________________________________________

opencpn / piolote raymarine 3Version imprimable de cet article Version imprimable

Publié Mars 2013, (màj Mars 2013) par : Nevermind   

Copyright : Les articles sont la propriété de leurs auteurs et ne peuvent pas être reproduits en partie ou totalité sans leur accord
S'identifier pour s'abonner par mail Inscrit aux forum vous pourriez transmettre cette page à un ami plaisancier

Bonjour,
Comme je suis un peu obstiné, j’ai retrouvé les bonnes phrases à envoyer pour asservir le pilote avec la route active sur opencpn.
Je sais c’est anecdotique, mais sur un long trajet sans vent pourquoi pas.
JP

NDLR : voir ci dessous l’article mis à jour :

http://www.plaisance-pratique.com/p...

UP


Répondre à cet article
(pour répondre à un message en particulier, voir plus bas dans le fil)

20 Messages de forum

__________________________________________________________________________________________________________________

__________________________________________________________________________________________________________________

  • 24 mars 2013 10:03, par Nevermind écrire     UP Animateur

    voilà les photos pour l’entrée :

    JPEG

    Répondre à ce message

  • 24 mars 2013 10:04, par Nevermind écrire     UP Animateur

    les photos en sorties

    JPEG

    Répondre à ce message

  • 24 mars 2013 10:04, par Nevermind écrire     UP Animateur

    la suite des photos

    JPEG

    Répondre à ce message

  • 24 mars 2013 10:06, par Nevermind écrire     UP Animateur

    Cela faisait beaucoup de combinaisons à tester !!!!!!!!!!!!!!!!!!!

    Répondre à ce message

  • 25 mars 2013 08:59, par Nevermind écrire     UP Animateur

    Bonjour,
    Les phrases NMEA se moquent de moi.
    Hier j’ai réussi à trouver les bonnes pour le pilote, un essai ce matin et voilà qu’il affiche « No data »
    Je ferme opencpn et lance maxsea et là le pilote reçoit bien les infos.
    Je ferme maxsea, lance opencpn et là ça marche !!!
    Je répète la manip en fermant le pc, le phénomène ré apparaît
    Même procédure et ça fonctionne à nouveau !

    Question :
    qu’est ce que maxsea peu bien activer comme phrase ?
    Sur maxsea il faut remplacer GLL par RMC pour afficher la position.
    Je pense que ça vient de là.......
    les phrases de sorties sont les mêmes que sur open.
    J’ai aussi essayé avec l’emulateur cela ne change rien.
    J’ai aussi supprimé GLL de l’entrée et la sortie : nada
    une idée ????

    Répondre à ce message

    • 25 mars 2013 11:43, par yvesD écrire     UP     Ce message répond à ... Animateur

      Un scénario très plausible : à l’état vierge (après reboot par ex) quelquechose dans l’OS n’est pas configuré comme il faut ;
      Lancer OpenCPN - qui ne sait pas configurer comme il faut - n’arrange rien, échec
      Lancer d’abord Maxsea, qui configure comme il faut (puisque ça marche) permet ensuite à OpenCPN de marcher car il bénéficie alors de cette bonne configuration.

      Ca peut être la piste à suivre pour trouver l’origine du mal.
      Ca peut être au niveau d’un driver série ou usb, ça n’est sans doute pas dans l’quipement en dehors du PC (« avec l’emulateur cela ne change rien ... »)

      C’est toujours ton autohelm/raytheon/raymarine/... ?
      Yves.

      PS : J’avais eu ça en 1983 avec un gros ordinateur à 300 MF et un disque configurable en 32 ou 36 bits, le cador de la maintenance (c’était maintenu à l’époque, sur site et avec des plans), lui, avait trouvé (booter VMS puis booter unix)

      Répondre à ce message

  • 26 mars 2013 14:18, par Nevermind écrire     UP Animateur

    Pour cette histoire d’activation du pilote, je suis en relation avec Nohal et Dave ( Cruiser) qui m’ont demandé les phrases NMEA de MaxSea et Opencpn.
    JP

    Répondre à ce message

    • 27 mars 2013 11:37, par Nevermind écrire     UP     Ce message répond à ... Animateur

      Quelques précisions.

      Le simple fait d’ouvrir MaxSea avec la centrale de navigation allumée suffit pour activer le pilote avec Opencpn.

      On peut supposer que MaxSea envoie des infos à la centrale SPX 30, mais avant cela passe par l’interface E85001.

      J’éteins la centrale de navigation, je la rallume et ça fonctionne encore !

      Là les infos sont gardées ;

      Comme l’as dit Yves, je ne pense pas que ce soit une histoire ni de matériel, ni de centrale de navigation.

      Mais quel sorte d’info MaxSea peut-il envoyer au PC via la centrale ?
      Et cette info est perdue à l’arrêt du PC.
      Mais MaxSea n’envoie que des phrases NMEA, et si j’ouvre MaxSea sans allumer la centrale , cela ne marche pas.

      Il n’est pas nécessaire d’avoir une route sur MaxSea.
      Alors ??????
      JP

      Répondre à ce message

  • 13 avril 2013 11:12, par Nicodefreja écrire     UP

    Je ne comprend pas pourquoi il y a 4 ports activés dans Open CPN, normalement un pour les datas et un pour l’AIS sont suffisants, non ? Peux tu décrire la fonctionnalité des ces ports ?

    Si le pilote n’a qu’un seul afficheur, alors l’interface 8500XX est inutile puisque le pilote possède une entrée et une sortie nmea, est il possible de faire un essai en branchant la db9 directement sur le pilote ? J’ai déjà vu des soucis de configuration avec cette interface :-(

    Répondre à ce message

  • 22 avril 2013 22:34, par fulup écrire     UP

    J’ai testé pas mal de solution pour expédier une route de OpenCPN vers mon pilote Raymarine, et au final seul un envoie direct en NMEA vers le contrôleur de pilote ST6002/6001 fonctionne.

    L’envoie en Seatalk (via un convertisseur Seatalk/RS232) vers mon C80 ne fonctionne pas, j’ai recu de raymarine un mail qui confirme que le C80 ne sait pas recevoir une route via Seatalk, et que pour la recevoir en NMEA il faut aller dans les menus et faire un import avant de pouvoir la revalider (trop merdique pour être viable) J’ai aussi testé l’envoie vers le calculateur du pilote « modèle S2 » en NMEA et ca ne fonctionne pas plus (ce que confirme aussi Raymarine).

    Au final la seule chose qui fonctionne chez moi, c’est d’expédier en NMEA-183 les route OpenCPN sur l’entrée du contrôleur de pilote (ST6001/6002). Avec sur OpenCPN le ports NMEA relié au contrôleur de pilote configuré en mode « écriture », il suffit de mettre la route active pour avoir la VMG, la distance du waypoint actif, etc. sur le contrôleur Raymarine. Quand OpenCPN arrive sur le Waypoint, il passe automatiquement au suivant et l’afficheur Raymarine est mis à jour sans aucune intervention.

    Je n’ai pas encore regardé ce que fait le pilote dans ce mode quand il est en mode « track » et notamment son comportement quand le waypoint actif change. Toutefois rien que d’avoir la VMG+CAP+Distance au waypoint directement dans le cockpit est déjà très intéressant.

    A noter que sur la photo, il y a une diode en // de la connexion NMEA. C’est le moyen le plus simple et le plus efficace que je connaisse pour vérifier qu’il y a un signal sur une ligne NMEA. Le tuyaux ma été donné par le service support de Digital Equipent quand je debugais mon AIS http://www.digitalyacht.co.uk/produ... et depuis je me demande comment j’ai pu vivre sans. Quand ca clignote c’est que les trames NMEA arrivent, quand c’est toujours allumé c’est que la diode est à l’envers, quand tout est éteint c’est qu’il n’y a pas de signal. Le petit adhésif rouge me permet de repérer facilement le + du NMEA, car je suis incapable de me souvenir si c’est la pate longue ou courte qui doit être connectée sur le « + ».

    JPEG

    Répondre à ce message

  • 12 juillet 2013 10:59, par Fulmar écrire     UP

    Je viens d’installer le pilote SPX5 avec la commande ST6002. Wind et OpenCpn 3.2.2 en sortie de multiplexeur vers un convertisseur NMEA-SeaTalk, vers une entrée SeaTalk de l’ordinateur du SPX5.

    La fonction Wind fonctionne sur le pilote.
    J’ai essayé la configuration recommandée par Nevermind, sans résultat.
    J’ai appliqué la recommandation usuelle « RMB » de Raymarine, sans plus de résultat.
    Dans les 2 cas, en display sur la commande j’ai bien le XTE, BTW et DTW renseignés, lorsqu’une route est active sur OpenCpn ; mais lorsque j’appuie sur « Track », la commande me dit « No data ».
    Cela peut-il être lié à ceci, contenu dans la recommandation de Raymarine, que je ne comprends pas : « Additional Note : Any Bearings need to be in Magnetic (preferred) ; otherwise, the SPX autopilot must receive True bearings with Variation so that the autopilot can convert the bearings to Magnetic.” ?

    Avez-vous une solution ou une explication du non fonctionnement ?
    ( ce n’est pas une affaire dramatique, dans la mesure où cette fonction devrait peut-être tout simplement être prohibée, c’est plus pour le fun et la compréhension…)
    Roland

    Répondre à ce message

    • 12 juillet 2013 11:17, par yoruk écrire     UP     Ce message répond à ... Animateur

      ( ce n’est pas une affaire dramatique, dans la mesure où cette fonction devrait peut-être tout simplement être prohibée, c’est plus pour le fun et la compréhension)

      Bonjour Roland
      Je me demande si ce malheureux OpenCPN, on ne lui en demande pas un peu plus qu’il ne peut faire...
      J’ai déjà des problèmes pour lui faire digérer des trace longues et précises.. :-O
      Michel

      Répondre à ce message

      • 12 juillet 2013 11:55, par Fulmar écrire     UP     Ce message répond à ...

        Bonjour Michel,
        Pour toi c’est donc que probablement OpenCpn ne pourrait pas. Je penchais plutôt que moi je ne savais pas faire marcher OpenCpn correctement.
        pas grave du tout.
        Par contre, je n’ai jamais rencontré de pb avec la trace.
        Je les nomme, exporte et supprime une fois pas semaine. Ensuite, pour les consulter, je les charge par couche.
        Roland

        Répondre à ce message

      • 12 juillet 2013 12:04, par Tiersp écrire     UP     Ce message répond à ...

        Bonjour,
        Je ne vois vraiment pas pourquoi ne pas utiliser cette fonction du PA très pratique dans certains cas.
        Avec un courant variable et une passe délicate, le pilote me place toujours à moins de 10m de la route et avec mon bateau il faut vraiment se concentrer pour faire auusi bien à la main, et pendant ce temps on ne peut pas bien regarder autour et intervenir si il y a quelque chose à faire.
        En solitaire, c’est une option interessante, bien sur pas dans tout les cas.
        Si il y a un problème, de plus il y a une alarme sonore qui ce déclenche.

        Avec OpenCPN 3.2.2 XP pro et le SPX10 cela fontionne bien.
        Juste une remarque importante IL FAUT UNE VITESSE SUPERIEURE A 3 NDS, sinon il met NO DATA.

        Répondre à ce message

Répondre à cet article

UP

Copyright et informations légales